Uploaded image for project: 'YADE - Yet Another Data Exchange Tool'
  1. YADE - Yet Another Data Exchange Tool
  2. YADE-563

Upgrade jcifs-ng from 2.0.6 to 2.1.5

    XMLWordPrintable

    Details

      Description

      Current Situation
      * YADE makes use of the CIFS interface library jcifs-ng version 2.0.6.

      • When used with high performance storage systems an error occurs as explained with YADE-564
      • YADE-564 resolves the issue, however, in order to be up to date with current jcifs-ng version YADE should switch to a current branch and user jcifs-ng 2.1.5. Use of a newer library introduces new dependencies and therefore requires adjustments of YADE.

      Desired Behavior

      • YADE ships with a current jcifs-ng library version 2.1.5

      Test instructions

      • Configure YADE using a SMB fragment
        • Check execution result
      • Check the ./lib/3d-party directory (JobScheduler Master, Agent and YADE Client) to find the files:
        • jcifs-ng-2.1.5.jar and
        • bcprov-jdk15on-1.66.jar

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                re Robert Ehrlich
                Reporter:
                ap Andreas Püschel
                Approver:
                Kanika Agrawal
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: