Uploaded image for project: 'YADE - Yet Another Data Exchange Tool'
  1. YADE - Yet Another Data Exchange Tool
  2. YADE-517

Support for Samba versions SMB1 and SMB2

    XMLWordPrintable

    Details

    • Type: Feature
    • Status: Released (View Workflow)
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.12.5
    • Component/s: YADE Client
    • Labels:
      None

      Description

      Current Situation

      • YADE supports use of the SMB protocol by using the JCIFS java library
      • JCIFS is a SMB1 only

      Desired Behaviour

      • YADE should support SMB1 and SMB2 protocols
        • A cleaned-up and improved version of the jCIFS library jcifs-ng will be used
        • The SMB protocol version should be automatically detected
        • To apply the additional jcifs-ng configuration properties use the SMBFragment / ConfigurationFiles element of the YADE XML configuration

      Previous JobScheduler versions

      • Patch for the previous JobScheduler versions 1.12.0-1.12.4 can be downloaded here.
      • Unzipt the patch to the ./lib/patches directory of the JobScheduler Master/Agent and perform a restart.

        Attachments

          Activity

            People

            • Assignee:
              re Robert Ehrlich
              Reporter:
              re Robert Ehrlich
              Approver:
              Mahendra Patidar
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: