JITL - JobScheduler Integrated Template Library
  1. JITL - JobScheduler Integrated Template Library
  2. JITL-547

Missing notifications when job/job chain is monitored by System Monitor

    Details

    • Type: Fix Fix
    • Status: Released (View Workflow)
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.12
    • Fix Version/s: 1.12.9
    • Labels:
      None

      Description

      Current Situation

      • When a job/job chain is being monitored by any System Monitor and the job/job chain is running in short intervals (2 minutes or 3 minutes) and the job has a script as "exit 9" then the System Monitor misses some entries i.e. System Monitor Dashboard does not generate the notification for each failure.

      How to reproduce

      • Unzip the attached job-configuration, copy it to the live folder.
      • Set your System Monitor to notify you for the attached job configuration.
      • Check the System Monitor notifications. Some of the entries will be missing from it.

      Desired Behavior

      • When a job/job chain is being monitored by a System Monitor, no entries should be missed by System Monitor.

        Activity

        Kanika Agrawal added a comment -

        The issue is fixed and is working as expected. The System Monitor does not miss any entry.

        • Tested with JobScheduler release dated 2019-04-09.

          People

          • Assignee:
            Robert Ehrlich
            Reporter:
            Mahendra Patidar
            Approver:
            Kanika Agrawal
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: